ios-personmd-notifications md-help-circle

Profile

  • Guest
    medal 0
  • Posts: 21
  • Post Likes: 3763

Notifications

  • No Unread Notifications

Game
Background changes to the race simulations.

warning
This thread is closed. Threads older than 6 weeks are closed automatically. To continue this discussion, create a new thread.
angle-double-left ios-arrow-back 1 ios-arrow-forward angle-double-right
medal 4865 VIEWER DEV
1 year 303 days ago (edited 1 year 303 days ago)
Hi there people,

We are all working very hard on issues people are seeing with the app on both mobile and web. While we are looking into and fixing them issues, we have looked into the Rain and advanced strategy issues the rest of you appear to be experiencing especially where the rain had stopped and the track was still wet.

First off sorry it has been so long to fix the issue, there is so many variables that have to be taken into consideration and when I thought I got all the issues sorted a different setup or weather pattern appeared to cause my fixes to break.

However i'm at a stage now where I believe I have gone through every possible combination I can think of and the race simulations appear to be doing exactly as expected.

As of 4pm GMT today I will be switching over to the new sim code, this will address the advanced strategy issues where the wrong tyre was fitted or the AI pitting you at the wrong time. I have also included some changes to the rate the track dries when it is not raining. It should dry quicker going forward. The wetting of the track as it rains will still be at the same rate.

I am going to note a few thing about the advanced strategy and how it will work going forward, I believe it is how people expected it to work however it wasn't working fully.

If the weather at the track you are racing is raining before the start of the race. It will only put on your wet weather start tyre if it is above your mm threshold. 

So if you have it set for wet tyres at 3mm and the track is 2.2mm before the race starts it will start you on your selected stint tyre then pit you for you wet tyres after it has passed the 3mm threshold.

If the track is 3.4mm it will start you on your wet start selected tyre.

One other note about the rain start tyre if it starts to rain mid race, if you are already on a the compound for a wet track the AI will not pit.

The rain stop selection will only be chosen if the wetness goes below the start tyre wetness in the above example 3mm, but also check the lap count you have set for the rain stop option.

So if you have Mediums set for 3 laps after the rain and the track goes down past 3mm then you will pit to put them on.

When the AI goes to do the automatic pit for the strategy, you will see the tyre compound selected will change to the tyre for that advanced strategy, so if it is over 3 mm it will change the selection to Wet. You can however cancel the pit for that lap if you want your driver to hold out a bit, or even change it to another compound selection. Note after you change the compound selection it will not use the option you chose for advanced strategy because you will be overriding that.

The same goes for putting on the rain stop selection.

When there is no rain and there is 0mm of track wetness it will select whatever tyre you have set for the next stint. Note here too that if you have wets set for your whole strategy it won't put on dry tyres unless you override this in the race.

As always, if you are still experiencing issues or you feel it does not act as described above, or you are just generally confused by this. Please let me know in this thread. We can look up your race log for up to 7 days after your race and I can work with that to better improve the AI if needed.

Dazaster
md-quotelink
medal 5889
1 year 303 days ago
So what happened to me in the race earlier today, will this be fixed in this new update you have just put into place? Link to the thread below
https://igpmanager.com/forum-thread/18056
md-quotelink
medal 4865 VIEWER DEV
1 year 303 days ago

Brad
So what happened to me in the race earlier today, will this be fixed in this new update you have just put into place? Link to the thread below
https://igpmanager.com/forum-thread/18056



Yes the changes should correct the wrongly fitted tyres
md-quotelink
medal 5457
1 year 303 days ago
The problem we had in the race last night was we were selecting to go from inters to inters and it put a couple of us on slicks. I got put on softs after selecting inters at the bottom menu for tyres. Do I need to make sure both tyre strategy menus are set since there are two different menus (one at the top of race screen and one at the bottom).
md-quotelink
medal 5712
1 year 302 days ago

J
The problem we had in the race last night was we were selecting to go from inters to inters and it put a couple of us on slicks. I got put on softs after selecting inters at the bottom menu for tyres. Do I need to make sure both tyre strategy menus are set since there are two different menus (one at the top of race screen and one at the bottom).



Same also but im guessing this will be fixed as of this? 

Had both cars go onto wrong tyres one onto slicks and the other to full wets. No where in any of the advanced or normal setting had i selected either of these tyres. My selection was for Inters for the whole race! Cost me the win last night but ill take it on the chin and move on. I even watched both cars go into the pits with the selection of Inters on and they came out wrong. No big deal but i guess the designers should know!
md-quotelink
medal 5615 SUPER MOD
1 year 302 days ago
Hi Graeme
These are the driver lap by lap data for your last race...
R Stanaway
C Waters

Neither driver appears to have been fitted with slick tyres, both had full wets fitted.
md-quotelink
medal 6198 MODERATOR
1 year 302 days ago
I want to tell you about my experience. Yesterday I started with W because 5 minutes before the race I did a test lap and there was 4 mm of rain, after just 4 laps the track arrived at 0.4 mm of water then I enter the pits to put the SS, after 3 laps automatically the car goes back into the pits and mounts the W, I realize the error and after 4 laps I mount the SS again, the next lap automatically the car I return to the pits and mounts the W again, so I am forced to return to the pits and mount a dry tire on which to do most of the race.
My automatic setting was I after 1mm of rain and SS after 6 laps that the track had dried.

md-quotelink
medal 5622
1 year 302 days ago
Thank you for this fix! This is how it should work!
md-quotelink
medal 5712
1 year 302 days ago

Kevin
Hi Graeme
These are the driver lap by lap data for your last race...
R Stanaway
C Waters

Neither driver appears to have been fitted with slick tyres, both had full wets fitted.

Sent you a message mate!!

md-quotelink
medal 4865 VIEWER DEV
1 year 302 days ago
Update:

After some reports last night it was noted that when the track had dried the sim thought the track was still wet. Also there was some reports about the car pitting for tyres it had already pitted for. 

I believe I have fixed both these instances and will have the new code deployed for 1pm GMT races.
md-quotelink
medal 6080
1 year 302 days ago
still something not working well, 
Today in Monaco started raining everything worked well until one point the water on the track jumped from 0.9 mm to 5 mm instantly.
at the begin it worked well 0.1 to 0.3 increase per lap.
md-quotelink
medal 6537 SUPER MOD
1 year 302 days ago (edited 1 year 302 days ago)
Don't cry guys. Re-run? Why? It was a funny race, different...
md-quotelink
medal 6080
1 year 302 days ago

Ovih
Don't cry guys. Re-run? Why? It was a funny race, different...


absolutely i handled it quite well, profited from the situation, i don't want a rerun just wanted mention that there is still a problem. i guess it is important information for the developers
md-quotelink
medal 6537 SUPER MOD
1 year 302 days ago

Bastian

Ovih
Don't cry guys. Re-run? Why? It was a funny race, different...


absolutely i handled it quite well, profited from the situation, i don't want a rerun just wanted mention that there is still a problem. i guess it is important information for the developers


Ok, now I understand you. The race was good for those who saw it. We should all be happy. :)
md-quotelink
medal 4865 VIEWER DEV
1 year 301 days ago
Hi All,

Firstly I apologise for this massive oversight, it came from me fixing the other issue with the rain not ever completely disappearing on the sim. When I ran tests I did it for that specific case, I didn't think it would affect the upper end of the rain.

A sim update was pushed just now, races starting from now on-wards (9:00 GMT) should get the right readouts.

I could of done this update last night but as it was peak times I believed at the time that it would of caused more upset by restarting all the back end servers with over 1000 races running. So I chose to do the update first thing this morning. If you want your races rerun please find the appropriate thread to request this.

Again i'm really sorry for the up and downs over the last few days, I do however feel that the worst of it is over.
md-quotelink
medal 5614
1 year 301 days ago (edited 1 year 301 days ago)
Before the race, the first problem, I could not save my tire choices until I had done all my tests.

At the moment of qualification it is raining (5mm). I start in W as desired. just after qualifying, rain stops.
At the start of the race, there is only 0.3mm of water. The run dried instantly.

Starting in W, I chose to go to the pit in the first lap to put SS
My driver goes to the pits and and he goes out of the pits in W on a dry run... my choice of fuel was taken into account, but not my choice of tires.

I also specify that I had set advanced options : "use I wet types if it stops raining for 50 laps", to avoid undesired change.

I do not see any reason why my driver came out in W

bungled race. it's not the first time it's happened to me

md-quotelink
angle-double-left ios-arrow-back 1 ios-arrow-forward angle-double-right

You must be logged in to post a reply.