ios-personmd-notifications md-help-circle

Profile

  • Guest
    medal 0
  • Posts: 21
  • Post Likes: 3763

Notifications

  • No Unread Notifications

Unresolved
Suspected race condition in Lap Record write operation

warning
This thread is closed. Threads older than 6 weeks are closed automatically. To continue this discussion, create a new thread.
angle-double-left ios-arrow-back 1 ios-arrow-forward angle-double-right
medal 5000
50 days ago
What did you try to do?
Check the race lap record of Monaco.

What happened instead?
The circuit overview tab of the race lap record says the lap record is 1:14.729, but it actually should be 1:14.703.
Screenshots:



Did the problem happen while using wi-fi, mobile data, or both?
Wi-fi

Did the bug happen in the app, on PC, or both?
PC

What operating system is your PC?
Windows 10

Which browser did you experience the problem in?
Microsoft Chromium Edge

Can the bug be reproduced?
I only picked one instance of this bug. This same bug occurs on many other Lap Records, such as Monaco quali and China quali.

Additional comments:
As I alluded to in the subject line, I suspect this is caused by a "race condition" caused by the write operation not being atomic (yes, I'm a programmer).
This seems to only happen when the correct lap record and the erroneous lap record are set in the same race (which is why I suspect it's a race condition. I hope you can write a script to loop through all of these 50 race IDs to fix this, and patch the code that caused this so it doesn't happen in the future.
md-quotelink
medal 6478
45 days ago
Cough... 1:14.588 :D :D

But yeah, seems like there was a bug for sure?
md-quotelink
angle-double-left ios-arrow-back 1 ios-arrow-forward angle-double-right

You must be logged in to post a reply.